Персональный блог Игоря Антонова aka "spider_net"

УТ11. Упр. организация или почему в списке организаций нельзя выбрать предопределенный элемент


Рубрика: Программирование -> 1С:Предприятие -> Администрирование
Метки: | | |
Просмотров: 868
УТ11. Упр. организация или почему в списке организаций нельзя выбрать предопределенный элемент

После обновления УТ11 у одного из клиентов возникла проблема оформления документов на не предопределенную организацию. Некоторые документы по умолчанию начали формироваться на управленческую организацию, хотя соответствующая опция не была активирована. Точно не помню версию релиза УТ11, начиная с которой разработчики добавили поддержку управленческой организации. Суть опции в следующем. Управленческая организация позволяет оформлять операции, которые должно отражаться только в управленческом, а не регламентированном учете.

С технической стороны все выглядит так. В справочнике “Организации” есть предопределенный элемент, представляющий управленческую организацию. Если не используется функциональная опция “ИспользоватьУправленческуюОрганизацию”, то в списке элементов справочника “Организации” вы не увидите предопределенный элемент, т.к. он фильтруется установленным отбором:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Если Параметры.Свойство("АвтоТест") Тогда // Возврат при получении формы для анализа.
		Возврат;
	КонецЕсли;
	Если Не ПолучитьФункциональнуюОпцию("ИспользоватьУправленческуюОрганизацию") Тогда
		Параметры.Отбор.Вставить("Предопределенный", Ложь);
	КонецЕсли;
	
КонецПроцедуры

Собственно говоря, если у вас нет необходимости в отражении документов только по управленческому учету, то никаких вопросов возникнуть не должно. У моего клиента ситуация аналогичная, но после установки пачки обновлений, заказы из интернет-магазина стали формироваться на управленческую организацию.

Документов, сформированных на управленческую организацию оказалось много, поэтому пришлось воспользоваться типовой обработкой “Поиск и замена значения”. Если вам требуется проделать аналогичную операцию, но в списке выбора организаций нет предопределенного элемента, то временно активируйте опцию “ИспользоватьУправленческуюОрганизацию”.

Включить применение управленческой организации можно так (на примере последнего релиза УТ11):

  • В главном меню выбираем “НСИ и администрирование” -> “Настройка параметров системы” -> “Предприятие” -> “Организации”.
  • Находим пункт “Раздельные операции закупок и продаж для упр. и регл. учета” и ставим на него флажок.
  • Все, теперь предопределенный элемент справочника “Организации” будет доступен для выбора. Можете, например, выбрать его в обработке “Поиск и замена значений” для массового переноса документов. После завершения всех операций - проделываем обратную операцию, т.е. снимаем флажок “Раздельные операции закупок и продаж для упр. и регл. учета”.

    Оставьте комментарий!
    comments powered by HyperComments