Персональный блог Игоря Антонова aka "spider_net"

1С:Предприятие 8.3. Проблема с публикацией информационной базы для работы через web


Рубрика: Администрирование -> 1С:Предприятие -> Без рамки
Метки: | | |
Просмотров: 3266
1С:Предприятие 8.3. Проблема с публикацией информационной базы для работы через web

На работе мы активно используем возможности платформы «1С:Предприятие 8.3» в качестве web-клиента. Проанализировав способы и затраты на разработку корпоративных приложений, мы решили сфокусироваться на технологиях от компании 1С. Это тема отдельного разговора, а сегодня мне бы хотелось поделиться решением небольшой проблемы, с которой мы столкнулись при публикации очередной информационной базы для работы через web.

Суть в следующем. Есть у нас отдельный сервер для информационных баз с которыми работают удаленные клиенты. Изначально у нас была опубликована одна информационная база (именно для работы через web), и все работало как часы. Сегодня мы решили разместить на этом же сервере новую ИБ и столкнулись с проблемой доступа к базе через web. Публикация из конфигуратора проходила нормально – «1С:Предприятие» внесло соответствующие изменения в конфигурационный файл Apache (мы используем именно этот web-сервер), но при попытке обратиться к публикуемой базе через браузер получали ошибку:

{"#exception":"{http://v8.1c.ru/8.2/virtual-resource-system}Exception","exception":{"clsid":"580392e6-ba49-4280-ac67-fcd6f2180121","reason":404,"descr":"HTTP: Not found\nОшибка при выполнении запроса GET к ресурсу /base"}}

С подобной ошибкой я раньше никогда не сталкивался и первым делом полез проверять конфиг в Apache. Ничего необычного там не увидел. Запись для второй публикуемой базы аналогичная той, которая уже работает. Следующим шагом проверил файлик vrd – тоже все ок. Было у меня предположение, что проблема может крыться в отсутствии прав доступа к директории с файликом vrd, но оказалось, что проблема не в этом.

Промучившись полчаса, решил обратиться за помощью в Google. Увы, кроме аналогичных вопросов ничего хорошего он мне не выдал. Пришлось отправлять к начальной точке и в очередной раз перебирать конфиги.

Не буду описывать дальнейшие действия, скажу лишь, что проблема оказалось в порядке записей опубликованных ИБ в самом конфигурационном файле Apache. Первая наша база была опубликована в корне, т.к. для нее был задан alias “/”. При обращении к site.com, Apache сразу переадресовывал на site.com/base1. Для новой ИБ мы выбрали другой алиас – «b2b/base» (условно) и из-за того, что он находился под «/» 1C возникала ошибка. Переставив записи местами (сначала новую базу, затем старую, которая в корне) – все заработало.

Если вы столкнулись с подобной проблемой – попробуйте мой способ решения. Ради теста я опубликовал еще несколько баз и никаких проблем с доступом не возникло.

Оставьте комментарий!
comments powered by HyperComments